Установка Metasploit в *NIX

Discussion in 'Безопасность и Анонимность' started by m1lo, 20 Jun 2009.

  1. m1lo

    m1lo Banned

    Joined:
    30 May 2009
    Messages:
    154
    Likes Received:
    4
    Reputations:
    0
    Установка Metasploit в Linux

    Metasploit Project - проект, посвященный информационной безопасности. Создан для предоставления информаци об уязвимости, помощи в создания сигнатур для IDS, создания и тестирования эксплоитов. Наиболее известен проект Metasploit Framework - удобная платформа для создания и отладки эксплоитов. Кроме того проект включает в себя базу опкодов, архив шеллкодов и информацию по исследованиям компьютерной безопасности.

    Перед тем как установить Metasploit нам необходимо установить следующие пакеты

    в Gentoo
    в Ubuntu, Debian
    ну в принципе некоторое пакеты может быть уже устанновленны у вас.

    Теперь собственно об установке:
    качаем сам Metasploit, для этого в консоли набираем
    Скачав, переходим в свою домашнюю папку , у меня это выглядит так
    ну вот впринципе и все, осталось только запустить)

    перейдя в каталог с распаковваным архивом
    пишем:
    для запуска в консоли
    для запуска его веб интерфейса, в консоле наберите
    ну а затем в строке адреса браузера введите http://127.0.0.1:55555
     
    #1 m1lo, 20 Jun 2009
    Last edited: 20 Jun 2009
  2. ph1l1ster

    ph1l1ster Elder - Старейшина

    Joined:
    11 Mar 2008
    Messages:
    398
    Likes Received:
    152
    Reputations:
    19
    нда...всем статьям статья.

    Тупо добавить сюда - http://forum.antichat.ru/thread21599.html

    Да и зачем? Кто знает линукс, никакого труда не составит установить.
     
    #2 ph1l1ster, 20 Jun 2009
    Last edited: 20 Jun 2009
  3. m1lo

    m1lo Banned

    Joined:
    30 May 2009
    Messages:
    154
    Likes Received:
    4
    Reputations:
    0
    да это может и нельзя назвать статьей, но заметьте что все писали под винду, а для людей которые юзают линукс хелпов почти не нашел, и решил вот накатать)
     
  4. m1lo

    m1lo Banned

    Joined:
    30 May 2009
    Messages:
    154
    Likes Received:
    4
    Reputations:
    0
    для новичков, тех кто учится, уверен что все когдато начинали, и знают как это когда нет материала для помощи)
     
  5. ph1l1ster

    ph1l1ster Elder - Старейшина

    Joined:
    11 Mar 2008
    Messages:
    398
    Likes Received:
    152
    Reputations:
    19

    Как нет? Wtf Тогда?

    Да и линукс это не винда. Если чего-то не хватает, Он сам тебе это скажет. И я уверен на 100% что люди которые только-только засели за линукс, сразу же метасплойт устанавливать не будут ;)
     
    #5 ph1l1ster, 20 Jun 2009
    Last edited: 20 Jun 2009
    1 person likes this.
  6. Forcer

    Forcer Elder - Старейшина

    Joined:
    12 Apr 2007
    Messages:
    321
    Likes Received:
    98
    Reputations:
    12
    Вообще, MF долгое время был только под линукс и потом только портировали на винду. Насчет установки - google по запросу "metasploit install" в первой десятке выдает 9 ссылок про установку на линукс и 1 на нокию.
     
  7. liquidcube

    liquidcube Member

    Joined:
    10 Apr 2009
    Messages:
    13
    Likes Received:
    10
    Reputations:
    0
    Для Fedora Core

    Вот дополнение - установка в Fedora.

    Ruby.
    Для неконсольного интерфейса рекомендуется :
    Скачать сам Метасплоит :
    Пользовать.

    **заметка**
    В багах это там как-то что-то решается для Ubuntu(читать было много и лень)
    В общем у меня и так всё работает. :rolleyes:
     
  8. Gray_f0x

    Gray_f0x Elder - Старейшина

    Joined:
    31 May 2007
    Messages:
    161
    Likes Received:
    84
    Reputations:
    12
    хм.. по-моему все ОЧЕНЬ детально описано в архиве с исходниками - файл README или INSTALL . Все очень просто.
     
  9. dyExplode

    dyExplode Elder - Старейшина

    Joined:
    13 Jan 2008
    Messages:
    62
    Likes Received:
    14
    Reputations:
    0
    думай что пишеш! метасплойт сначала писался на перле а потом на раби, а это интерпретируемые языки и следовательно приложение кроссплатформенное так как интерпритаторы есть и под линь и под БСД и под мастдай и под мак ось. и поэтому Он не мог писаться под чтото и не под что не портировался. интерпретируемые приложение и слово портироваться между собой никак не связаны. это тоже самое сказать что формат мп3 создавался для винды а потом Его портировали под линь, а также под магнитофоны, магнитолы и плееры.
     
  10. Brooklyn111

    Brooklyn111 New Member

    Joined:
    13 Feb 2011
    Messages:
    54
    Likes Received:
    0
    Reputations:
    0
    Всем привет, ну а как в линуксе установить metasploit pro, сборка бэктрек 5, скачал установочный файл ну а как дальше вообще незнаю.
     
  11. dmg

    dmg Member

    Joined:
    31 Oct 2011
    Messages:
    172
    Likes Received:
    12
    Reputations:
    0
    полезная статья,linux поставил не давно и только сейчас приступил к изучению,ну и как следовало ожидать возникают даже простые вопросы,а гайдов которые подробно описывают установку и работу не так много,потому что кажется у всех сложившееся мнение предвзятое - юзаешь Linux разбирайся во всем сам . Бред.
     
  12. neofit

    neofit Member

    Joined:
    14 Nov 2009
    Messages:
    228
    Likes Received:
    14
    Reputations:
    0
    Что интересует???
     
  13. uCryNet

    uCryNet Member

    Joined:
    11 Mar 2012
    Messages:
    51
    Likes Received:
    13
    Reputations:
    5
    Норм. Как-раз нужно было :)
     
Loading...