Проблемы с видеокартой nVidia GeForce в fedora 12

Discussion in 'Безопасность и Анонимность' started by mstdmstd, 4 Mar 2010.

  1. mstdmstd

    mstdmstd New Member

    Joined:
    21 Feb 2010
    Messages:
    3
    Likes Received:
    0
    Reputations:
    0
    Всем привет
    Установил русскую fedora 12
    При вводе uname -r выдает : 2.6.31.5-127.fc12.i686.PAE
    У меня видеокарта nVidia GeForce 9600 GT
    Тут http://forums.fedoraforum.org/showpost.php?p=1114769&postcount=1 нашел как ставить nvidia драйверы
    так и сделал

    nVidia стать стала Но остались проблемы с настройкой
    Чуть подробнее :
    После выполнения yum erase xorg-x11-drv-nouveau и перезагрузки удалось удалить nouveau
    и команда lsmod|grep nouveau выводит пустую строку

    После установки

    yum install kernel-devel gcc
    yum install kernel-PAE-devel
    и
    rpm -Uvh http://download1.rpmfusion.org/free/fedora/rpmfusion-free-release-stable.noarch.rpm http://download1.rpmfusion.org/nonfree/fedora/rpmfusion-nonfree-release-stable.noarch.rpm

    - сообщил что пакет более поздней версии уже установлен

    yum install kmod-nvidia-PAE

    -нормально стал

    мелькнули варнинги
    W: Possible missing firmware ql8100_fw.bin for module qla2xxx.ko
    W: Possible missing firmware aic94xx-seq.fw for module aic94xx.ko

    Но по-тому что я нашел в нете это не существенно ?

    Команда

    lsmod|grep nvidia

    выводит :
    nvidia 8872876 38
    i2c_core 23392 2 nvidia,i2c_nforce2

    после чистки логов в файле /var/log/Xorg.0.log(я его приведу в конце - он немаленький) я вижу что nvidia стал нормально и
    явных ошибок нет :

    Проблема в том что посидев даже с полчаса я чувствую как устают глаза

    ------------ у меня такой файл xorg.conf-----------------
    # Xorg configuration created by livna-config-display

    Section "Files"
    ModulePath "/usr/lib/xorg/modules/extensions/nvidia"
    ModulePath "/usr/lib/xorg/modules"
    EndSection

    Section "ServerFlags"
    Option "AIGLX" "on"
    EndSection

    Section "Device"
    Identifier "Videocard0"
    Driver "nvidia"
    Option "AddARGBGLXVisuals" "True"
    EndSection

    Section "Extensions"
    Option "Composite" "Enable"
    EndSection

    Я добавил в него такие строки пытаясь установить частоту 75 hz:

    Section "Screen"
    Identifier "Screen0"
    Device "Videocard0"
    DefaultDepth 24
    SubSection "Display"
    Viewport 0 0
    Depth 24
    Modes "1280x1024_75"
    EndSubSection
    EndSection

    и после чистки лога и перегрузке я вижу в логе:
    ...
    (II) Mar 03 11:20:30 NVIDIA(0): Validated modes:
    (II) Mar 03 11:20:30 NVIDIA(0): "1280x1024_75"
    (II) Mar 03 11:20:30 NVIDIA(0): Virtual screen size determined to be 1280 x 1024
    ...
    (II) Mar 03 11:20:31 NVIDIA(0): Setting mode "1280x1024_75"
    ...
    Опять таки никаких ошибок в логе нет - но для глаз это невыносимо или дело не в частоте? А в чем тогда?
    Как еще сожно тестировать видеокарту ? Если она вроде и есть а сидеть под ней невозможно...

    В system->Dispaly выставляемая частота из списка auto/50hz/51hz...
    А есть ли команда проверить какая частота установлена на самом деле?

    команда
    xvidtune
    выдает :
    Unable to query monitor info

    И еще после установке и перегрузки появились проблемы что при клике на системном меню
    или на пиктограмках где сгруппировано более 1 версии программы все виснет секунд на 5-6 и только после этого появляется менюшка с элементами...

    Добавлю что эта видеокарта у меня уже с полгода и под Windows XP проблем нет - сижу за компопм по 8-10 часов каждый день
    Первоначальный лог /var/log/Xorg.0.log после установки nVidia:

    X.Org X Server 1.7.1
    Release Date: 2009-10-23
    X Protocol Version 11, Revision 0
    Build Operating System: 2.6.18-164.2.1.el5
    Current Operating System: Linux localhost.localdomain 2.6.31.12-174.2.22.fc12.i686.PAE #1 SMP Fri Feb 19 19:10:04 UTC 2010 i686
    Kernel command line: ro root=UUID=31157df2-0f90-4d3a-919f-f88922211bd8 nomodeset LANG=en_US.UTF-8 SYSFONT=latarcyrheb-sun16 KEYBOARDTYPE=pc KEYTABLE=us rhgb quiet rdblacklist=nouveau
    Build Date: 05 November 2009 07:43:20PM
    Build ID: xorg-x11-server 1.7.1-7.fc12
    Current version of pixman: 0.16.2
    Before reporting problems, check http://bodhi.fedoraproject.org/
    to make sure that you have the latest version.
    Markers: (--) probed, (**) from config file, (==) default setting,
    (++) from command line, (!!) notice, (II) informational,
    (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
    (==) Log file: "/var/log/Xorg.0.log", Time: Wed Mar 3 05:52:36 2010
    (==) Using config file: "/etc/X11/xorg.conf"
    (==) No Layout section. Using the first Screen section.
    (==) No screen section available. Using defaults.
    (**) |-->Screen "Default Screen Section" (0)
    (**) | |-->Monitor "<default monitor>"
    (==) No device specified for screen "Default Screen Section".
    Using the first device section listed.
    (**) | |-->Device "Videocard0"
    (==) No monitor specified for screen "Default Screen Section".
    Using a default monitor configuration.
    (**) Option "AIGLX" "on"
    (==) Automatically adding devices
    (==) Automatically enabling devices
    (==) FontPath set to:
    catalogue:/etc/X11/fontpath.d,
    built-ins
    (**) ModulePath set to "/usr/lib/xorg/modules/extensions/nvidia,/usr/lib/xorg/modules"
    (**) Extension "Composite" is enabled
    (II) Cannot locate a core pointer device.
    (II) Cannot locate a core keyboard device.
    (II) The server relies on HAL to provide the list of input devices.
    If no devices become available, reconfigure HAL or disable AllowEmptyInput.
    (II) Loader magic: 0x821b0a0
    (II) Module ABI versions:
    X.Org ANSI C Emulation: 0.4
    X.Org Video Driver: 6.0
    X.Org XInput driver : 7.0
    X.Org Server Extension : 2.0
    (++) using VT number 1

    (--) PCI:*(0:2:0:0) 10de:0622:0000:0000 nVidia Corporation G94 [GeForce 9600 GT] rev 161, Mem @ 0xdf000000/16777216, 0xc0000000/268435456, 0xdc000000/33554432, I/O @ 0x0000ec00/128, BIOS @ 0x????????/524288
    (II) LoadModule: "extmod"
    (II) Loading /usr/lib/xorg/modules/extensions/libextmod.so
    (II) Module extmod: vendor="X.Org Foundation"
    compiled for 1.7.1, module version = 1.0.0
    Module class: X.Org Server Extension
    ABI class: X.Org Server Extension, version 2.0
    (II) Loading extension SELinux
    (II) Loading extension MIT-SCREEN-SAVER
    (II) Loading extension XFree86-VidModeExtension
    (II) Loading extension XFree86-DGA
    (II) Loading extension DPMS
    (II) Loading extension XVideo
    (II) Loading extension XVideo-MotionCompensation
    (II) Loading extension X-Resource
    (II) LoadModule: "dbe"
    (II) Loading /usr/lib/xorg/modules/extensions/libdbe.so
    (II) Module dbe: vendor="X.Org Foundation"
    compiled for 1.7.1, module version = 1.0.0
    Module class: X.Org Server Extension
    ABI class: X.Org Server Extension, version 2.0
    (II) Loading extension DOUBLE-BUFFER
    (II) LoadModule: "glx"
    (II) Loading /usr/lib/xorg/modules/extensions/nvidia/libglx.so
    (II) Module glx: vendor="NVIDIA Corporation"
    compiled for 4.0.2, module version = 1.0.0
    Module class: X.Org Server Extension
    (II) NVIDIA GLX Module 190.53 Tue Dec 8 20:47:42 PST 2009
    (II) Loading extension GLX
    (II) LoadModule: "record"
    (II) Loading /usr/lib/xorg/modules/extensions/librecord.so
    (II) Module record: vendor="X.Org Foundation"
    compiled for 1.7.1, module version = 1.13.0
    Module class: X.Org Server Extension
    ABI class: X.Org Server Extension, version 2.0
    (II) Loading extension RECORD
    (II) LoadModule: "dri"
    (II) Loading /usr/lib/xorg/modules/extensions/libdri.so
    (II) Module dri: vendor="X.Org Foundation"
    compiled for 1.7.1, module version = 1.0.0
    ABI class: X.Org Server Extension, version 2.0
    (II) Loading extension XFree86-DRI
    (II) LoadModule: "dri2"
    (II) Loading /usr/lib/xorg/modules/extensions/libdri2.so
    (II) Module dri2: vendor="X.Org Foundation"
    compiled for 1.7.1, module version = 1.1.0
    ABI class: X.Org Server Extension, version 2.0
    (II) Loading extension DRI2
    (II) LoadModule: "nvidia"
    (II) Loading /usr/lib/xorg/modules/drivers/nvidia_drv.so
    (II) Module nvidia: vendor="NVIDIA Corporation"
    compiled for 4.0.2, module version = 1.0.0
    Module class: X.Org Video Driver
    (II) NVIDIA dlloader X Driver 190.53 Tue Dec 8 19:16:02 PST 2009
    (II) NVIDIA Unified Driver for all Supported NVIDIA GPUs
    (II) Primary Device is: PCI 02@00:00:0
    (II) Loading sub module "fb"
    (II) LoadModule: "fb"
    (II) Loading /usr/lib/xorg/modules/libfb.so
    (II) Module fb: vendor="X.Org Foundation"
    compiled for 1.7.1, module version = 1.0.0
    ABI class: X.Org ANSI C Emulation, version 0.4
    (II) Loading sub module "wfb"
    (II) LoadModule: "wfb"
    (II) Loading /usr/lib/xorg/modules/libwfb.so
    (II) Module wfb: vendor="X.Org Foundation"
    compiled for 1.7.1, module version = 1.0.0
    ABI class: X.Org ANSI C Emulation, version 0.4
    (II) Loading sub module "ramdac"
    (II) LoadModule: "ramdac"
    (II) Module "ramdac" already built-in
    (II) NVIDIA(0): Creating default Display subsection in Screen section
    "Default Screen Section" for depth/fbbpp 24/32
    (==) NVIDIA(0): Depth 24, (==) framebuffer bpp 32
    (==) NVIDIA(0): RGB weight 888
    (==) NVIDIA(0): Default visual is TrueColor
    (==) NVIDIA(0): Using gamma correction (1.0, 1.0, 1.0)
    (**) NVIDIA(0): Option "AddARGBGLXVisuals" "True"
    (**) Mar 03 05:52:36 NVIDIA(0): Enabling RENDER acceleration
    (II) Mar 03 05:52:36 NVIDIA(0): Support for GLX with the Damage and Composite X extensions is
    (II) Mar 03 05:52:36 NVIDIA(0): enabled.
    (II) Mar 03 05:52:38 NVIDIA(0): NVIDIA GPU GeForce 9600 GT (G94) at PCI:2:0:0 (GPU-0)
    (--) Mar 03 05:52:38 NVIDIA(0): Memory: 524288 kBytes
    (--) Mar 03 05:52:38 NVIDIA(0): VideoBIOS: 62.94.82.00.00
    (II) Mar 03 05:52:38 NVIDIA(0): Detected PCI Express Link width: 16X
    (--) Mar 03 05:52:38 NVIDIA(0): Interlaced video modes are supported on this GPU
    (--) Mar 03 05:52:38 NVIDIA(0): Connected display device(s) on GeForce 9600 GT at PCI:2:0:0:
    (--) Mar 03 05:52:38 NVIDIA(0): ViewSonic VA902 (CRT-0)
    (--) Mar 03 05:52:38 NVIDIA(0): ViewSonic VA902 (CRT-0): 400.0 MHz maximum pixel clock
    (II) Mar 03 05:52:38 NVIDIA(0): Assigned Display Device: CRT-0
    (==) Mar 03 05:52:38 NVIDIA(0):
    (==) Mar 03 05:52:38 NVIDIA(0): No modes were requested; the default mode "nvidia-auto-select"
    (==) Mar 03 05:52:38 NVIDIA(0): will be used as the requested mode.
    (==) Mar 03 05:52:38 NVIDIA(0):
    (II) Mar 03 05:52:38 NVIDIA(0): Validated modes:
    (II) Mar 03 05:52:38 NVIDIA(0): "nvidia-auto-select"
    (II) Mar 03 05:52:38 NVIDIA(0): Virtual screen size determined to be 1280 x 1024
    (--) Mar 03 05:52:38 NVIDIA(0): DPI set to (85, 86); computed from "UseEdidDpi" X config
    (--) Mar 03 05:52:38 NVIDIA(0): option
    (**) Mar 03 05:52:38 NVIDIA(0): Enabling 32-bit ARGB GLX visuals.
    (--) Depth 24 pixmap format is 32 bpp
    (II) Mar 03 05:52:38 NVIDIA(0): Initialized GPU GART.
    (II) Mar 03 05:52:38 NVIDIA(0): Setting mode "nvidia-auto-select"
    (II) Loading extension NV-GLX
    (II) Mar 03 05:52:38 NVIDIA(0): Initialized OpenGL Acceleration
    (==) NVIDIA(0): Disabling shared memory pixmaps
    (II) Mar 03 05:52:38 NVIDIA(0): Initialized X Rendering Acceleration
    (==) NVIDIA(0): Backing store disabled
    (==) NVIDIA(0): Silken mouse enabled
    (==) NVIDIA(0): DPMS enabled
    (II) Loading extension NV-CONTROL
    (II) Loading extension XINERAMA
    (==) RandR enabled
    (II) Initializing built-in extension Generic Event Extension
    (II) Initializing built-in extension SHAPE
    (II) Initializing built-in extension MIT-SHM
    (II) Initializing built-in extension XInputExtension
    (II) Initializing built-in extension XTEST
    (II) Initializing built-in extension BIG-REQUESTS
    (II) Initializing built-in extension SYNC
    (II) Initializing built-in extension XKEYBOARD
    (II) Initializing built-in extension XC-MISC
    (II) Initializing built-in extension XINERAMA
    (II) Initializing built-in extension XFIXES
    (II) Initializing built-in extension RENDER
    (II) Initializing built-in extension RANDR
    (II) Initializing built-in extension COMPOSITE
    (II) Initializing built-in extension DAMAGE
    (II) SELinux: Disabled by boolean
    (II) Initializing extension GLX
    record: RECORD extension enabled at configure time.
    record: This extension is known to be broken, disabling extension now..
    record: http://bugs.freedesktop.org/show_bug.cgi?id=20500
    (II) config/hal: Adding input device AT Translated Set 2 keyboard
    (II) LoadModule: "evdev"
    (II) Loading /usr/lib/xorg/modules/input/evdev_drv.so
    (II) Module evdev: vendor="X.Org Foundation"
    compiled for 1.7.0, module version = 2.3.0
    Module class: X.Org XInput Driver
    ABI class: X.Org XInput driver, version 7.0
    (**) AT Translated Set 2 keyboard: always reports core events
    (**) AT Translated Set 2 keyboard: Device: "/dev/input/event3"
    (II) AT Translated Set 2 keyboard: Found keys
    (II) AT Translated Set 2 keyboard: Configuring as keyboard
    (II) XINPUT: Adding extended input device "AT Translated Set 2 keyboard" (type: KEYBOARD)
    (**) Option "xkb_rules" "evdev"
    (**) Option "xkb_model" "pc105+inet"
    (**) Option "xkb_layout" "us"
    (**) Option "xkb_options" "terminate:ctrl_alt_bksp"
    (II) config/hal: Adding input device Macintosh mouse button emulation
    (**) Macintosh mouse button emulation: always reports core events
    (**) Macintosh mouse button emulation: Device: "/dev/input/event2"
    (II) Macintosh mouse button emulation: Found 3 mouse buttons
    (II) Macintosh mouse button emulation: Found relative axes
    (II) Macintosh mouse button emulation: Found x and y relative axes
    (II) Macintosh mouse button emulation: Configuring as mouse
    (**) Macintosh mouse button emulation: YAxisMapping: buttons 4 and 5
    (**) Macintosh mouse button emulation: EmulateWheelButton: 4, EmulateWheelInertia: 10, EmulateWheelTimeout: 200
    (II) XINPUT: Adding extended input device "Macintosh mouse button emulation" (type: MOUSE)
    (**) Macintosh mouse button emulation: (accel) keeping acceleration scheme 1
    (**) Macintosh mouse button emulation: (accel) acceleration profile 0
    (II) Macintosh mouse button emulation: initialized for relative axes.
    (II) config/hal: Adding input device PS/2+USB Mouse
    (**) PS/2+USB Mouse: always reports core events
    (**) PS/2+USB Mouse: Device: "/dev/input/event4"
    (II) PS/2+USB Mouse: Found 3 mouse buttons
    (II) PS/2+USB Mouse: Found scroll wheel(s)
    (II) PS/2+USB Mouse: Found relative axes
    (II) PS/2+USB Mouse: Found x and y relative axes
    (II) PS/2+USB Mouse: Configuring as mouse
    (**) PS/2+USB Mouse: YAxisMapping: buttons 4 and 5
    (**) PS/2+USB Mouse: EmulateWheelButton: 4, EmulateWheelInertia: 10, EmulateWheelTimeout: 200
    (II) XINPUT: Adding extended input device "PS/2+USB Mouse" (type: MOUSE)
    (**) PS/2+USB Mouse: (accel) keeping acceleration scheme 1
    (**) PS/2+USB Mouse: (accel) acceleration profile 0
    (II) PS/2+USB Mouse: initialized for relative axes.
    (II) config/hal: Adding input device Power Button
    (**) Power Button: always reports core events
    (**) Power Button: Device: "/dev/input/event1"
    (II) Power Button: Found keys
    (II) Power Button: Configuring as keyboard
    (II) XINPUT: Adding extended input device "Power Button" (type: KEYBOARD)
    (**) Option "xkb_rules" "evdev"
    (**) Option "xkb_model" "evdev"
    (**) Option "xkb_layout" "us"
    (II) config/hal: Adding input device Power Button
    (**) Power Button: always reports core events
    (**) Power Button: Device: "/dev/input/event0"
    (II) Power Button: Found keys
    (II) Power Button: Configuring as keyboard
    (II) XINPUT: Adding extended input device "Power Button" (type: KEYBOARD)
    (**) Option "xkb_rules" "evdev"
    (**) Option "xkb_model" "evdev"
    (**) Option "xkb_layout" "us"
     
  2. zythar

    zythar Elder - Старейшина

    Joined:
    16 Feb 2008
    Messages:
    518
    Likes Received:
    109
    Reputations:
    5
    чтобы поставить "[Modes "1280x1024_75"]" нужно сначала модлайн для этого написать, а у вас модлайна нет. в гугле полно инфы как этот самый модлайн писать.
    даже калькуляторы специальные есть. вводишь разрешение экрана и частоту и тебе готовую строчку дают.
     
Loading...