Counter-strike 1.6 server on freebsd

Discussion in 'Безопасность и Анонимность' started by -=Dem0n=-, 29 Oct 2011.

  1. -=Dem0n=-

    -=Dem0n=- Elder - Старейшина

    Joined:
    15 Mar 2007
    Messages:
    66
    Likes Received:
    4
    Reputations:
    0
    установил сервер
    такая петрушка немогу запустить с внешним ip
    с внутренним проблем нет.

    WARNING: UDP_OpenSocket: port: 27015 bind: Cannot assign requested address
    FATAL ERROR (shutting down): Couldn't allocate dedicated server IP port 27015.

    порт не используется, внешний ip правильный
    с +ip xxx.xxx.xxx.xxx и нулями без ip тоже запускать пробывал таже самая ошибка
    может быть firewall блокирует порт? как его добавить в исключения хотя на локалке то работает..
    в настройке модема порт в исключениях..

    по теме нашел это в гугле:
    The additional ips arent enabled so my host is doing it right now!! I'll let everyone know if it fixed that!!
    Yup problem solved they just needed to enable extra ips!

    но так и не понял что это.
     
  2. -=Dem0n=-

    -=Dem0n=- Elder - Старейшина

    Joined:
    15 Mar 2007
    Messages:
    66
    Likes Received:
    4
    Reputations:
    0
    почему команда netstat выдает локальный ip 192.168.153.128, через который и запускается сервер, а в настройках модема LAN-IP: 192.168.2.1 ?
    непонимаю %(
     
  3. Timon132009

    Timon132009 Member

    Joined:
    7 Jun 2009
    Messages:
    137
    Likes Received:
    19
    Reputations:
    0
    Ну так запусти сервер с локальным IP и потом просто в модеме пробрось порт 27015
     
  4. -=Dem0n=-

    -=Dem0n=- Elder - Старейшина

    Joined:
    15 Mar 2007
    Messages:
    66
    Likes Received:
    4
    Reputations:
    0
    так и сделал. проблема в том что сервер с локальным ip виден только на компьютере котором он запущен. у меня есть еще один комп который подключен к тойже сети но он не видит сервак.
    инет на котором сервер подключен так:
    Кабельный модем > беспроводной/LAN адаптер > Wlan
    порт открывал на "адаптере"


    закрыл порт в модеме сервер всёравно запустился с локальным ip freebsd теперь я вообще ничего не понимаю.
     
    #4 -=Dem0n=-, 29 Oct 2011
    Last edited: 29 Oct 2011
  5. -=Dem0n=-

    -=Dem0n=- Elder - Старейшина

    Joined:
    15 Mar 2007
    Messages:
    66
    Likes Received:
    4
    Reputations:
    0
    ввобщем исправил проблему добавлением ip адресов через ifconfig...
    хорошо сервер запускается с адремами вписанными там
    но подключится к нему невозможно(хотя запускаю с параметром sv_lan 0
    Connection to Steam servers successful.
    сервер запустился нормально и т.д.
    только вод подключится к нему невозможно в контре
    в чем может быть проблема?
    п.с.
    прочил факи про настройку сервера для интернета добвил
    ip адреса в server.cfg такого вида setmaster add ip
    при старте сервер выдает:
    NET_SendPacket ERROR: CAnnot assign requested address
    и таких строк куча
     
Loading...