Установка rpm на FreeBsd 8.1

Discussion in 'FreeBSD' started by Vudaev, 7 Nov 2012.

  1. Vudaev

    Vudaev New Member

    Joined:
    26 Aug 2012
    Messages:
    3
    Likes Received:
    2
    Reputations:
    0
    Хелп пытаюсь поставить мультифон мегафоновский на FreeBsd 8.1
    скачал rpm пакет с офф сайта
    пишу в консоли :
    Code:
     
    usr# rpm --install multifon_2.0_linux.rpm
    ошибка: неудовлетворенные зависимости:
            /bin/sh   нужен для MultiFon-1.22.465-1
            /bin/sh   нужен для MultiFon-1.22.465-1
            /bin/sh   нужен для MultiFon-1.22.465-1
            /bin/sh   нужен для MultiFon-1.22.465-1
            /bin/sh   нужен для MultiFon-1.22.465-1
            libX11.so.6   нужен для MultiFon-1.22.465-1
            libXext.so.6   нужен для MultiFon-1.22.465-1
            libXss.so.1   нужен для MultiFon-1.22.465-1
            libasound.so.2   нужен для MultiFon-1.22.465-1
            libasound.so.2(ALSA_0.9)   нужен для MultiFon-1.22.465-1
            libasound.so.2(ALSA_0.9.0rc4)   нужен для MultiFon-1.22.465-1
            libc.so.6   нужен для MultiFon-1.22.465-1
            libc.so.6(GLIBC_2.0)   нужен для MultiFon-1.22.465-1
            libc.so.6(GLIBC_2.1)   нужен для MultiFon-1.22.465-1
            libc.so.6(GLIBC_2.1.3)   нужен для MultiFon-1.22.465-1
            libc.so.6(GLIBC_2.3)   нужен для MultiFon-1.22.465-1
            libc.so.6(GLIBC_2.3.2)   нужен для MultiFon-1.22.465-1
            libc.so.6(GLIBC_2.3.4)   нужен для MultiFon-1.22.465-1
            libc.so.6(GLIBC_2.4)   нужен для MultiFon-1.22.465-1
            libc.so.6(GLIBC_2.7)   нужен для MultiFon-1.22.465-1
            libgcc_s.so.1   нужен для MultiFon-1.22.465-1
            libgcc_s.so.1(GCC_3.0)   нужен для MultiFon-1.22.465-1
            libgcc_s.so.1(GLIBC_2.0)   нужен для MultiFon-1.22.465-1
            libjpeg.so.62   нужен для MultiFon-1.22.465-1
            libm.so.6   нужен для MultiFon-1.22.465-1
            libm.so.6(GLIBC_2.0)   нужен для MultiFon-1.22.465-1
            libm.so.6(GLIBC_2.1)   нужен для MultiFon-1.22.465-1
            libpthread.so.0   нужен для MultiFon-1.22.465-1
            libpthread.so.0(GLIBC_2.0)   нужен для MultiFon-1.22.465-1
            libpthread.so.0(GLIBC_2.1)   нужен для MultiFon-1.22.465-1
            libpthread.so.0(GLIBC_2.3.3)   нужен для MultiFon-1.22.465-1
            libpulse.so.0   нужен для MultiFon-1.22.465-1
            libpulse.so.0(PULSE_0)   нужен для MultiFon-1.22.465-1
            librt.so.1   нужен для MultiFon-1.22.465-1
            librt.so.1(GLIBC_2.2)   нужен для MultiFon-1.22.465-1
            libstdc++.so.6   нужен для MultiFon-1.22.465-1
            libstdc++.so.6(CXXABI_1.3)   нужен для MultiFon-1.22.465-1
            libstdc++.so.6(GLIBCXX_3.4)   нужен для MultiFon-1.22.465-1
            libstdc++.so.6(GLIBCXX_3.4.11)   нужен для MultiFon-1.22.465-1
            libstdc++.so.6(GLIBCXX_3.4.9)   нужен для MultiFon-1.22.465-1
            rtld(GNU_HASH)   нужен для MultiFon-1.22.465-1
    
    
    что делать?
     
  2. 2c9

    2c9 Member

    Joined:
    7 Feb 2011
    Messages:
    53
    Likes Received:
    7
    Reputations:
    1
    удовлетворять!!! м?
     
  3. krizis

    krizis Banned

    Joined:
    12 Jun 2008
    Messages:
    189
    Likes Received:
    10
    Reputations:
    0
    всегда удивляют люди, ставя линь...
    и при этом не понимаю простых вещей.
    даже в гугле спроси,он тут же ответит на такой простой вопрос...
     
  4. Vudaev

    Vudaev New Member

    Joined:
    26 Aug 2012
    Messages:
    3
    Likes Received:
    2
    Reputations:
    0
    каким боком можно поставить /bin/sh ? ставил linux_base но чего то не помогло
     
  5. Vudaev

    Vudaev New Member

    Joined:
    26 Aug 2012
    Messages:
    3
    Likes Received:
    2
    Reputations:
    0
    хелп
     
  6. 2c9

    2c9 Member

    Joined:
    7 Feb 2011
    Messages:
    53
    Likes Received:
    7
    Reputations:
    1
    нудык поставь что он хочет: либы для gcc stdc++ и че посчитаешь нужным и попробуй поиграться с опциями --ignoreos --nodep --force
    не забудь предварительно почитать хелп и ман, могут возникнуть проблемки

    в данный момент нет под рукой freebsd
     
Loading...