Распаковка и разборка CPE KuWfi

Discussion in 'Беспроводные технологии/Wi-Fi/Wardriving' started by Triton_Mgn, 7 Mar 2017.

  1. Af5G4337

    Af5G4337 Member

    Joined:
    17 Dec 2016
    Messages:
    86
    Likes Received:
    36
    Reputations:
    0
    Да... Облом... У меня прошивка CPE-AP-V2.0-Build20161021103806 и в ней нет такого пункта меню. :(:mad:
    А у Вас какая версия?
    И закладки Firewall нет. И если не выделен пункт в меню слева, то справа ничего не отбражается. У Вас в каком пункте эти настройки?
     
    #581 Af5G4337, 30 Sep 2017
    Last edited: 30 Sep 2017
  2. Kevin Shindel

    Kevin Shindel Well-Known Member

    Joined:
    24 May 2015
    Messages:
    977
    Likes Received:
    1,154
    Reputations:
    61
    CPE830-AP-V2.0-Build20161021103806

    [​IMG]
     
    Triton_Mgn and Af5G4337 like this.
  3. Af5G4337

    Af5G4337 Member

    Joined:
    17 Dec 2016
    Messages:
    86
    Likes Received:
    36
    Reputations:
    0
    Преогромнейшая Вам благодарность за вновь открытые пункты меню! Видать пока я менял имя своей железки на андроид, пока делал доступ по ssh что-то зацепил и они пропали. Теперь они есть. Но какой бы МАС я не выставил в поле MAC clone, естественно с установленной галкой и нажатием apply, СРЕшка к донору цепляется своим заводским МАСом... Вы не могли бы проверить как с этим на Вашей железке? Еще раз Спасибо!
     
  4. freee

    freee Active Member

    Joined:
    8 Aug 2015
    Messages:
    212
    Likes Received:
    227
    Reputations:
    4
    https://yadi.sk/d/q7Yseobp3NMSXx - исправил несколько косяков, добавил чекбокс отметить\снять все (а то долго в ручную тыкать точки с плохим сигналом)
     
    Kevin Shindel and Triton_Mgn like this.
  5. khamyk

    khamyk Well-Known Member

    Joined:
    30 Dec 2013
    Messages:
    534
    Likes Received:
    329
    Reputations:
    0
    MAC clone не работает,не мучайся.И мак не меняется,похоже что драйвер не даёт.
     
    Af5G4337 likes this.
  6. Af5G4337

    Af5G4337 Member

    Joined:
    17 Dec 2016
    Messages:
    86
    Likes Received:
    36
    Reputations:
    0
    Я уже понял это. Новый mac сохраняется но похоже для wan ethernet. Завтра проверю, отпишу. Китайцы пишут о какой-то коммерческой тайне по поводу смены адреса, молчат одним словом... Но как говорится будем рыть дальше! Очень уж сладко железка работает.
     
    Triton_Mgn likes this.
  7. Af5G4337

    Af5G4337 Member

    Joined:
    17 Dec 2016
    Messages:
    86
    Likes Received:
    36
    Reputations:
    0
    Вообщем mac clone сохраняет данные только для web морды СРЕшки... Интерфейсы которые видны в putty ath0, br-lan, eth0, eth1, wifi0 свой mac не меняют попробую написать китайсу, что типа его устройство не выполняет заявленных в меню функций, пусть подергается, а то он мне про секрет фирмы начинает рассказывать. Да и спор еще можо открыть.
    Вообщем смена mac для wlan или как они его обзывают, пока актуальна! По крайней мере для меня.
     
  8. freee

    freee Active Member

    Joined:
    8 Aug 2015
    Messages:
    212
    Likes Received:
    227
    Reputations:
    4
    Область где храниться МАС - находиться по адресу 0x1fff_1000 ( 0xfff - это обманка для роутеров на nor_flash, которая говорит что область данных находиться в конце флешки размером 64кб - не трудно догадаться что это ART, и в этой области по:
    адресу 0000 (в самом начале )находится МАС 12 байт к примеру у Kevin_Shindel - 78 D3 8D FD E8 31 78 D3 8D FD E8 32 (lan и wan соостветственно)
    адресу 1000 находится art wmac начинается с 2х байт 02 02 потом 6 байт МАС 78 D3 8D FD E8 33 (ОБРАТИТЕ ВНИМАНИЕ ПОСЛЕДНЯЯ ЦИФРА НА 2 БОЛЬШЕ ЧЕМ МАС это wifi)
    Если вы вдруг не сделали бэкап - ничего страшного - зная это можно восстановить роутер со своим мас адресом
    Вот и вся коммерческая тайна, которая есть в исходниках для компиляции опенврт или в datasheet.
     
    Af5G4337, binarymaster and Payer like this.
  9. freee

    freee Active Member

    Joined:
    8 Aug 2015
    Messages:
    212
    Likes Received:
    227
    Reputations:
    4
    Af5G4337
    дайте вывод свохи
    cat /etc/config/network
    cat /etc/config/wireless
    после этих команд
    uci set network.wan.macaddr="00:00:00:00:00:01"
    uci commit network
    ifdown wan && ifup wan
     
  10. alexgtr

    alexgtr New Member

    Joined:
    3 Dec 2015
    Messages:
    6
    Likes Received:
    0
    Reputations:
    0
    Друзья, скажите, а comfast 214n можно использовать для вардрайвинга? В режим монитора переходит? Пакеты air-crack, reaver прикручиваются?
     
  11. freee

    freee Active Member

    Joined:
    8 Aug 2015
    Messages:
    212
    Likes Received:
    227
    Reputations:
    4
    Да к любому прикручивается, если есть исходники драйвера открытом виде. Снимаешь лог загрузки ( размер spi, оперативка, разметка gpio, задействованные порты под lan wan - ) а самое главное проц, и ищешь аналог твоего роутера в опенврт, все несоответствия правишь под свои. Тоже с загрузчиком, подбираешь под свой проц
     
  12. alexgtr

    alexgtr New Member

    Joined:
    3 Dec 2015
    Messages:
    6
    Likes Received:
    0
    Reputations:
    0
    Но я так понял вы не знаете никого кто уже реализовал это на практике?
     
  13. freee

    freee Active Member

    Joined:
    8 Aug 2015
    Messages:
    212
    Likes Received:
    227
    Reputations:
    4
    С конкретной моделью нет ( а вообще так каждая модель добавляется ) опенврт забросили, но с леде вы можете попытать удачу, там есть фору, спросите мб кто нибудь и добавит устройство. В этой ветке обсуждается друга модель, на другом железе. ( Надею автор ветки почистит тему за нами, и в следующий раз в ЛС пишите если не по теме)

    Но если вы ошиблись и у вас CF-E214N ver2.0 - то это клон нашего и прошивка и загрузчик подойдут
     
  14. alexgtr

    alexgtr New Member

    Joined:
    3 Dec 2015
    Messages:
    6
    Likes Received:
    0
    Reputations:
    0
    К сожалению первая ревизия. В свое время ее ух-ех советовал. Говорил, что по скорости и по дальности не хуже юбиквити. Живу в частном секторе. Где-то в 400-600 метрах прямой видимости 14-и этажка. Прифигачил я комфаст на мачту от эфирной антенны, но скорости нормальной не получил. Может интернет медленный был у того кого взломал, может еще чего... В общем решил я ее к спутниковой тарелке приделать для усиления сигнала. А пока искал тарелку, в наш район пришел местный провайдер с оптикой и 100мб\с. Вот и осталась эта приблуда, не знаю, что с ней делать теперь. Покупал в свое время за 3000р. А теперь продавать в 3 раза дешевле как-то жаба душит, потому что уже есть аналоги в виде второй ревизии комфаста и kuwfi за 2500р, но получше по характеристикам. Вот и подумал, что вдруг можно для вардрайвинга использовать. Очень удобно бы было. Довольно мощная антенна и адаптер в одном корпусе. Но как видно не судьба. А kuwfi уже кто-нибудь использовал для вардрайвинга?
     
  15. Af5G4337

    Af5G4337 Member

    Joined:
    17 Dec 2016
    Messages:
    86
    Likes Received:
    36
    Reputations:
    0
    Freee


    root@android-addffO38ce4d2def:~# cat /etc/config/network

    config interface 'loopback'
    option ifname 'lo'
    option proto 'static'
    option ipaddr '127.0.0.1'
    option netmask '255.0.0.0'

    config interface 'lan'
    option ifname 'eth0 eth1'
    option type 'bridge'
    option ipaddr '192.168.188.253'
    option netmask '255.255.255.0'
    option yuncore_ipaddr '192.168.188.253'
    option yuncore_netmask '255.255.255.0'
    option mtu '1500'
    option proto 'static'

    config interface 'wan'
    option proto 'dhcp'
    option mtu '1500'
    option macaddr '78:31:c1:cd:91:46'

    config mgt 'mgt'
    option mgt_port '8080'
    option mac_clone '00:EC:80:F9:7C:E5'

    config config 'qos'
    option disable '1'
    option up_rate '1024000'
    option down_rate '1024000'
    option rule_num '0'

    config switch
    option name 'switch0'
    option reset '1'
    option enable_vlan '1'

    root@android-addffO38ce4d2def:~# cat /etc/config/wireless

    config wifi-device 'wifi0'
    option type 'qcawifi'
    option country 'CN'
    option channel '7'
    option htmode 'HT20'
    option hwmode '11ng'
    option AMPDU '1'
    option rssi_thres '-95'
    option acktimeout '64'
    option txpower '3'

    config wifi-device 'wifi1'
    option type 'qcawifi'
    option country 'CN'
    option channel '153'
    option hwmode '11ac'
    option htmode 'HT40'
    option txpower '30'
    option rssi_thres '-90'
    option AMPDU '1'
    option acktimeout '64'
    option disabled '1'

    config wifi-iface
    option device 'wifi0'
    option id '00'
    option encryption 'psk2+tkip+ccmp'
    option wmm '1'
    option hidden '0'
    option bintval '100'
    option shortgi '1'
    option frag '2346'
    option rts '2346'
    option maxsta '64'
    option isolate '0'
    option wds '1'
    option extap '1'
    option disablecoext '1'
    option nawds_mode '0'
    option ssid 'Keenetic-3542'
    option disabled '0'
    option mode 'sta'
    option network 'wan'
    option key 'y5jrR89M'

    config wifi-iface
    option device 'wifi0'
    option id '01'
    option mode 'ap'
    option encryption 'none'
    option ssid 'VAP0'
    option network 'lan'
    option wmm '1'
    option hidden '0'
    option disabled '1'
    option bintval '100'
    option shortgi '1'
    option frag '2346'
    option rts '2346'
    option maxsta '64'
    option isolate '0'
    option wds '1'
    option extap '1'
    option disablecoext '1'
    option nawds_mode '0'

    config wifi-iface
    option device 'wifi0'
    option id '02'
    option mode 'ap'
    option encryption 'none'
    option ssid 'VAP1'
    option network 'lan'
    option wmm '1'
    option hidden '0'
    option disabled '1'
    option bintval '100'
    option shortgi '1'
    option frag '2346'
    option rts '2346'
    option maxsta '64'
    option isolate '0'
    option wds '1'
    option extap '1'
    option disablecoext '1'

    config wifi-iface
    option device 'wifi0'
    option id '03'
    option mode 'ap'
    option encryption 'none'
    option ssid 'VAP2'
    option network 'lan'
    option wmm '1'
    option hidden '0'
    option disabled '1'
    option bintval '100'
    option shortgi '1'
    option frag '2346'
    option rts '2346'
    option maxsta '64'
    option isolate '0'
    option wds '1'
    option extap '1'
    option disablecoext '1'

    config wifi-iface
    option device 'wifi1'
    option id '10'
    option mode 'ap'
    option encryption 'psk2+tkip+ccmp'
    option key '66666666'
    option ssid 'Wireless 5.8G'
    option network 'lan'
    option wmm '1'
    option hidden '0'
    option bintval '100'
    option shortgi '1'
    option frag '2346'
    option rts '2346'
    option maxsta '64'
    option isolate '0'
    option wds '1'
    option extap '1'
    option disablecoext '1'
    option nawds_mode '0'
    option disabled '0'

    config wifi-iface
    option device 'wifi1'
    option id '11'
    option mode 'ap'
    option encryption 'none'
    option ssid 'VAP0'
    option network 'lan'
    option wmm '1'
    option hidden '0'
    option disabled '1'
    option bintval '100'
    option shortgi '1'
    option frag '2346'
    option rts '2346'
    option maxsta '64'
    option isolate '0'
    option wds '1'
    option extap '1'
    option disablecoext '1'

    config wifi-iface
    option device 'wifi1'
    option id '12'
    option mode 'ap'
    option encryption 'none'
    option ssid 'VAP1'
    option network 'lan'
    option wmm '1'
    option hidden '0'
    option disabled '1'
    option bintval '100'
    option shortgi '1'
    option frag '2346'
    option rts '2346'
    option maxsta '64'
    option isolate '0'
    option wds '1'
    option extap '1'
    option disablecoext '1'

    config wifi-iface
    option device 'wifi1'
    option id '13'
    option mode 'ap'
    option encryption 'none'
    option ssid 'VAP2'
    option network 'lan'
    option wmm '1'
    option hidden '0'
    option disabled '1'
    option bintval '100'
    option shortgi '1'
    option frag '2346'
    option rts '2346'
    option maxsta '64'
    option isolate '0'
    option wds '1'
    option extap '1'
    option disablecoext '1'

    root@android-addffO38ce4d2def:~# uci set network.wan.macaddr="00:00:00:00:00:01"
    root@android-addffO38ce4d2def:~# uci commit network
    root@android-addffO38ce4d2def:~# ifdown wan && ifup wan
    Error for wireless request "Set Fragmentation Threshold" (8B24) :
    SET failed on device ath0 ; Invalid argument.
    Interface doesn't accept private ioctl...
    maxsta (8BE0): Invalid argument
    Successfully initialized wpa_supplicant
    root@android-addffO38ce4d2def:~# dmsg
    -ash: dmsg: not found
    root@android-addffO38ce4d2def:~# etc/config/firewall
    -ash: etc/config/firewall: not found
    root@android-addffO38ce4d2def:~#
    Промахнулся, в личке ответил. Это то, что Вы хотели видеть?
    Соединение с роутером на котором настроен фильтр установлено.
     
    #595 Af5G4337, 2 Oct 2017
    Last edited: 2 Oct 2017
  16. yx-ex

    yx-ex Well-Known Member

    Joined:
    14 May 2011
    Messages:
    756
    Likes Received:
    787
    Reputations:
    10
    Ну вполне себе норм 214й.Он у меня снова во владении,как и 2 вуйфуя.Вполне отлично работает и справляется со своими задачами.Конечно же вуйфуи то получше работают,ну оно и немудрено- 2T2R и 300 мегабит против 1T1R и 150 мегабит.Прогресс то не стоит на месте.Кстати,разбирал его-там обычный модуль стоит,и антенна к нему на один конец накинута,можео попробовать взять вторую антенну,и на второй конец накинуть ради эксперимента)).Но пока лень-и так нормально работает.Да и владение 2мя Аиргридами,2мя вуйфуями,1м Тплинком 7210 и 1м 214-ым не располагают к началу экспериментов над радиомостом-вайфаев дома как грязи и че то неохота нарушать идилию...))
     
    Payer likes this.
  17. Kevin Shindel

    Kevin Shindel Well-Known Member

    Joined:
    24 May 2015
    Messages:
    977
    Likes Received:
    1,154
    Reputations:
    61
    Нашел такой себе мануал по прошивке через UART для TP-Link'ов может быть полезен для нашего фуйвуя.
     
  18. saimonyz

    saimonyz Member

    Joined:
    23 Jun 2012
    Messages:
    162
    Likes Received:
    41
    Reputations:
    2
    freee

    можно пару скриншотов web-интерфейса прошивки то что ты делал
     
  19. freee

    freee Active Member

    Joined:
    8 Aug 2015
    Messages:
    212
    Likes Received:
    227
    Reputations:
    4
    https://yadi.sk/i/dz7M7O6C3NmRzL - скрин главной страницы ( сделаю еще интересующих вас - скажите каких вкладок)
    https://yadi.sk/d/1JNJBokc3NmS8K - новая версия с исправлениями
     
  20. Af5G4337

    Af5G4337 Member

    Joined:
    17 Dec 2016
    Messages:
    86
    Likes Received:
    36
    Reputations:
    0
    Freee
    Скажите, а как насчет отката на заводскую?