Установка Metasploit на Raspberry Pi

Discussion in 'Песочница' started by Dr_Wile, 26 Apr 2017.

  1. Dr_Wile

    Dr_Wile Member

    Joined:
    19 Oct 2016
    Messages:
    121
    Likes Received:
    52
    Reputations:
    2
    Здравствуйте, тут такое дело...В общем необходимо поставить msfconsole на raspberry pi, сама малинка работает под ОС Raspbian. Cколько я не пробовал методик, описанны на дестках сайтов у меня не выходило.
    Could not find gem sqlite3, which is required by gem metasploit-framework, in any of the sources. Кто знает решение этой проблемы? Всем заранее спасибо за ответ!
     
  2. user100

    user100 Moderator

    Joined:
    24 Dec 2011
    Messages:
    3,576
    Likes Received:
    11,449
    Reputations:
    348
    Установить sqlite3?
    А вообще почему бы сразу Кали Линух не накатить с всем фаршем на борту - как раз есть под Малину версия.
     
    _________________________
  3. Dr_Wile

    Dr_Wile Member

    Joined:
    19 Oct 2016
    Messages:
    121
    Likes Received:
    52
    Reputations:
    2
    Кали уже ставил, в нём не стоит изначально metasploit в нём не установлен. Не установлена так же графическая соединялка с Wi-FI точками, можно конечно (в теории) через консоль подключиться к AP, но у меня не получилось. Sqlite3 ставил, но метасплоит всё равно не завёлся, ругаясь на sqlite3. Прив вводе комманды root@pi: /opt/metasploit-framework# bundle install появляется ошибка "make sure that 'gem install ffi -v '1.9.18', succeds before bundling
     
  4. artkar

    artkar Well-Known Member

    Joined:
    14 Nov 2016
    Messages:
    351
    Likes Received:
    330
    Reputations:
    6
    В технических требования для метаса стоит:
    OPERTING SYSTEM
    • Ubuntu Linux 14.04 LTS (RECOMMENDED)
    • Ubuntu Linux 16.04 LTS
    • Microsoft Windows Serv 2008 R2
    • Microsoft Windows Serv 2012 R2
    • Microsoft Windows 8.1
    • Microsoft Windows 7 SP1+
    • Red Hat Enterprise Linux Server 7.1 or later
    • Red Hat Enterprise Linux Server 6.5 or later
    • Red Hat Enterprise Linux Server 5.10 or later

    Что-то я не вижу в списке ОС Raspbian?
     
  5. Dr_Wile

    Dr_Wile Member

    Joined:
    19 Oct 2016
    Messages:
    121
    Likes Received:
    52
    Reputations:
    2
    Но люди же пишут статьи, рассказывают как они устанавливают на Raspbian Metasploit. Возможно, у них до того как они решили напечатать статью по этому поводу, стояли какие-то дополнительные пакеты. Во-вторых: Вы в этом списке так же не видите ОС Kali и Parrot которые точно также как Raspbian базируются на Debian Linux, тем не менее каким-то чудом удаётся запускать на Kali и Parrot Metasploit. Поправьте если я не прав
     
  6. SooLFaa

    SooLFaa Members of Antichat

    Joined:
    17 Mar 2014
    Messages:
    526
    Likes Received:
    489
    Reputations:
    146
    Этот вопрос подробненько описан в моей статье https://forum.antichat.ru/threads/449560/
    Здесь есть ответ и на Ваш вопрос. А так же может быть, что нибудь ещё для себя подчерпнете.
     
    _________________________
    atata and Veil like this.
  7. artkar

    artkar Well-Known Member

    Joined:
    14 Nov 2016
    Messages:
    351
    Likes Received:
    330
    Reputations:
    6
    Ну в этих ваших инторнетах много всякой херни пишут, тут вы имеете дело с высокообразованными специалистами, которые не читают што пишут в этих ваших инторнетах, а дают рекомендации используя техническую документацию производителей программного обеспечения.
    Итак по сути вопроса:
    Што касается Кали. Кали стоит особняком, с боку припёку, её то поддерживают то не поддерживают, то включают метасплоит фраймворк в состав Кали, то не включают. Кали 1.1 не поддерживаеться, Кали 2.0 начала поддерживаться с октября 15-го года, но поддержка касается только коммерческих продуктов с закрытым исходным кодом таких как Metasploit Community, Express, Pro, они сильно отличаются от свободнораспространяемых продуктов, особенно их установка.
    Что касаться распбери. Как говориться в крылатой фразе из известного синема и "зайца можно научить курить", однако компания Рапид7© слезно просит не использовать не поддерживаемые платформы и не заниматься самодеятельностью
     
  8. Veil

    Veil Banned

    Joined:
    21 May 2015
    Messages:
    2,049
    Likes Received:
    3,417
    Reputations:
    72
    Это с каких понтов Дебиан Джесси ,стал обособленный.Да ОСь строгая,но острая.Но почти Убунта,это тебе не SLAX.
    Ты прямо Мао дзе Дун .Великий кормчий и отец всех народов. Уймись китаец.;)
    БабаДук сказал бы тебе ехай на хуй,но с ошибками.(не режиссерская, а исправленная версия.)
     
    #8 Veil, 28 Apr 2017
    Last edited: 28 Apr 2017
Loading...