Обновление glibc

Discussion in 'Безопасность и Анонимность' started by RaiDeRz, 22 Oct 2007.

  1. RaiDeRz

    RaiDeRz Elder - Старейшина

    Joined:
    5 Apr 2007
    Messages:
    121
    Likes Received:
    5
    Reputations:
    0
    Никак немогу обновить glibc
    Помогите как его обновить, вот логи, у него все время конфликт идет с тем, а у другого пакета тоже такой же конфликс и хер знает как их вместе удружить

    Code:
    [root@ ~]# rpm -i glibc-2.3.6-3.i386.rpm
    warning: glibc-2.3.6-3.i386.rpm: Header V3 DSA signature: NOKEY, key ID 4f2a6fd2
    error: Failed dependencies:
            glibc-common = 2.3.6-3 is needed by glibc-2.3.6-3.i386
            glibc > 2.3.5 conflicts with glibc-common-2.3.5-10.3.i386
    [root@ ~]# rpm -i glibc-common-2.3.6-3.i386.rpm
    warning: glibc-common-2.3.6-3.i386.rpm: Header V3 DSA signature: NOKEY, key ID 4f2a6fd2
    error: Failed dependencies:
            glibc < 2.3.6 conflicts with glibc-common-2.3.6-3.i386
    
     
  2. [_Keeber-PUNK_]

    Joined:
    6 Oct 2007
    Messages:
    25
    Likes Received:
    10
    Reputations:
    3
    а у тебя точно на кампе i386 архитектура?
     
  3. RaiDeRz

    RaiDeRz Elder - Старейшина

    Joined:
    5 Apr 2007
    Messages:
    121
    Likes Received:
    5
    Reputations:
    0
    У меня VDS и в саппорте вроде сказали что i386 можно

    P.S. ОС: FC4, нужно просто обновить через yum до FC5
     
  4. igorf()x

    igorf()x Elder - Старейшина

    Joined:
    17 Oct 2007
    Messages:
    138
    Likes Received:
    52
    Reputations:
    5
    И если через yum обновление делается, то зачем через rpm ставить ?
    Можно просто: yum install glibc-2.3.6-3.i386.rpm (yum upgrade <пакет> - вообще обновлять так надо)

    Тем более что он пишет за отсутсвующие зависимости... которые надо до него установить.


    А если через rpm то надо с
    --nodeps
    (Не проверять зависимости перед установкой или обновлением пакета).

    --noorder (Не переупорядочивать список устанавливаемых пакетов. Обычно список переупорядочивается для удовлетворения зависимостей).
     
    #4 igorf()x, 22 Oct 2007
    Last edited: 22 Oct 2007
  5. RaiDeRz

    RaiDeRz Elder - Старейшина

    Joined:
    5 Apr 2007
    Messages:
    121
    Likes Received:
    5
    Reputations:
    0
    А при установке через yum вот такое писал у меня (поэтому решил вручную через rpm): Missing Dependency: glibc-common = 2.3.5-10.3 is needed by package glibc-dummy-fedora-core-4

    А при установке с --nodeps ошибки вида:
    Code:
     file /usr/libexec/pt_chown from install of glibc-common-2.3.6-3 conflicts with file from package glibc-common-2.3.5-10.3
            file /usr/sbin/build-locale-archive from install of glibc-common-2.3.6-3 conflicts with file from package glibc-common-2.3.5-10.3
            file /usr/sbin/rpcinfo from install of glibc-common-2.3.6-3 conflicts with file from package glibc-common-2.3.5-10.3
            file /usr/sbin/zdump from install of glibc-common-2.3.6-3 conflicts with file from package glibc-common-2.3.5-10.3
    P.S. навсякий случай вырезка из состава пакетов этих:
    Code:
    [root@ ~]# rpm -qa | grep glibc
    glibc-2.3.5-10.3
    glibc-dummy-fedora-core-4-2.3.5-10.3.swsoft
    glibc-common-2.3.5-10.3
     
    #5 RaiDeRz, 23 Oct 2007
    Last edited: 23 Oct 2007
  6. igorf()x

    igorf()x Elder - Старейшина

    Joined:
    17 Oct 2007
    Messages:
    138
    Likes Received:
    52
    Reputations:
    5
    Тогда попробовать yum remove <пакет > - должен удалить вместе с зависимостями....

    И потом yum install <пакет>
     
  7. MicRO

    MicRO Member

    Joined:
    28 Oct 2004
    Messages:
    274
    Likes Received:
    75
    Reputations:
    49
    conflicts with file from package glibc-common-2.3.5-10.3
    написано же русским языком :) расшифровываю "удали меня"
     
Loading...